summaryrefslogtreecommitdiffstats
path: root/disas/meson.build
diff options
context:
space:
mode:
authorRichard Henderson2020-09-12 19:47:33 +0200
committerRichard Henderson2020-10-03 11:25:14 +0200
commitf343346b147b8871d628defa4fe038eb1a2e4e08 (patch)
tree9659a5f01a79cccacf9c7e0dcaf48dbfcb252ecc /disas/meson.build
parentdisas: Configure capstone for aarch64 host without libvixl (diff)
downloadqemu-f343346b147b8871d628defa4fe038eb1a2e4e08.tar.gz
qemu-f343346b147b8871d628defa4fe038eb1a2e4e08.tar.xz
qemu-f343346b147b8871d628defa4fe038eb1a2e4e08.zip
disas: Split out capstone code to disas/capstone.c
There is nothing target-specific about this code, so it can be added to common_ss. This also requires that the base capstone dependency be added to common_ss, so that we get the correct include paths added to CFLAGS. Reviewed-by: Alex Bennée <alex.bennee@linaro.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'disas/meson.build')
-rw-r--r--disas/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/disas/meson.build b/disas/meson.build
index bde8280c73..09a852742e 100644
--- a/disas/meson.build
+++ b/disas/meson.build
@@ -21,5 +21,6 @@ common_ss.add(when: 'CONFIG_S390_DIS', if_true: files('s390.c'))
common_ss.add(when: 'CONFIG_SH4_DIS', if_true: files('sh4.c'))
common_ss.add(when: 'CONFIG_SPARC_DIS', if_true: files('sparc.c'))
common_ss.add(when: 'CONFIG_XTENSA_DIS', if_true: files('xtensa.c'))
+common_ss.add(when: capstone, if_true: files('capstone.c'))
specific_ss.add(when: 'CONFIG_TCG_INTERPRETER', if_true: files('tci.c'))