summaryrefslogtreecommitdiffstats
path: root/docs/meson.build
diff options
context:
space:
mode:
authorPeter Maydell2020-09-25 18:23:09 +0200
committerMarkus Armbruster2020-09-29 17:55:39 +0200
commitb3f4830ab398f6e66cda986835e9b5be567e3e49 (patch)
treeac317ff6bd6fbc57d538171bf8eff1b79981bbd8 /docs/meson.build
parentmeson.build: Move SPHINX_ARGS to top level meson.build file (diff)
downloadqemu-b3f4830ab398f6e66cda986835e9b5be567e3e49.tar.gz
qemu-b3f4830ab398f6e66cda986835e9b5be567e3e49.tar.xz
qemu-b3f4830ab398f6e66cda986835e9b5be567e3e49.zip
meson.build: Make manuals depend on source to Sphinx extensions
The automatic dependency handling for Sphinx manuals only makes the output depend on the input documentation files. This means that if you edit the Python source of an extension then the documentation won't be rebuilt. Create a list of all the source files for the extensions and add it to the dependencies for the manuals. This is similar to how we handle the qapi_gen_depends list. Because we don't try to identify which manuals are using which Sphinx extensions, a change to the source of one extension will always rebuild the entire manual set, not merely the manuals which have changed. This is acceptable because we don't change the extensions all that often. Signed-off-by: Peter Maydell <peter.maydell@linaro.org> Message-Id: <20200925162316.21205-15-peter.maydell@linaro.org> Reviewed-by: Markus Armbruster <armbru@redhat.com> [Re rebuilding the enitre manual set being acceptable "because we don't change the extensions all that often": we also rebuild it when the QAPI generator code the qapidoc extension depends on changes. This will inconvenience QAPI developers. Can't be helped now.] Signed-off-by: Markus Armbruster <armbru@redhat.com>
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/docs/meson.build b/docs/meson.build
index 52e384be17..0340d489ac 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -36,6 +36,7 @@ if build_docs
output: [manual + '.stamp'],
input: [files('conf.py'), files(manual / 'conf.py')],
depfile: manual + '.d',
+ depend_files: sphinx_extn_depends,
command: [SPHINX_ARGS, '-Ddepfile=@DEPFILE@',
'-Ddepfile_stamp=@OUTPUT0@',
'-b', 'html', '-d', private_dir,