summaryrefslogtreecommitdiffstats
path: root/docs/meson.build
diff options
context:
space:
mode:
authorStefan Reiter2021-01-28 15:58:01 +0100
committerPaolo Bonzini2021-02-08 14:43:55 +0100
commite0f7fc588d735f23b36fdaf16b6c81f804348cb0 (patch)
tree94f979a133dc3dec97d9f47050858413c8f47387 /docs/meson.build
parentfuzz: fix wrong index in clear_bits (diff)
downloadqemu-e0f7fc588d735f23b36fdaf16b6c81f804348cb0.tar.gz
qemu-e0f7fc588d735f23b36fdaf16b6c81f804348cb0.tar.xz
qemu-e0f7fc588d735f23b36fdaf16b6c81f804348cb0.zip
docs: don't install corresponding man page if guest agent is disabled
No sense outputting the qemu-ga and qemu-ga-ref man pages when the guest agent binary itself is disabled. This mirrors behaviour from before the meson switch. Signed-off-by: Stefan Reiter <s.reiter@proxmox.com> Message-Id: <20210128145801.14384-1-s.reiter@proxmox.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'docs/meson.build')
-rw-r--r--docs/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/docs/meson.build b/docs/meson.build
index bb14eaebd3..f84306ba7e 100644
--- a/docs/meson.build
+++ b/docs/meson.build
@@ -46,9 +46,11 @@ if build_docs
meson.source_root() / 'docs/sphinx/qmp_lexer.py',
qapi_gen_depends ]
+ have_ga = have_tools and config_host.has_key('CONFIG_GUEST_AGENT')
+
man_pages = {
- 'qemu-ga.8': (have_tools ? 'man8' : ''),
- 'qemu-ga-ref.7': 'man7',
+ 'qemu-ga.8': (have_ga ? 'man8' : ''),
+ 'qemu-ga-ref.7': (have_ga ? 'man7' : ''),
'qemu-qmp-ref.7': 'man7',
'qemu-storage-daemon-qmp-ref.7': (have_tools ? 'man7' : ''),
'qemu-img.1': (have_tools ? 'man1' : ''),