summaryrefslogtreecommitdiffstats
path: root/hw/char/meson.build
diff options
context:
space:
mode:
authorVijai Kumar K2021-04-01 20:14:56 +0200
committerAlistair Francis2021-05-11 12:02:05 +0200
commit07f334d89d47cba59f8f47fdc8f5983234487801 (patch)
tree2777eadd9396e9d4af57abda7ba8122a0c29c8b8 /hw/char/meson.build
parentriscv: Add initial support for Shakti C machine (diff)
downloadqemu-07f334d89d47cba59f8f47fdc8f5983234487801.tar.gz
qemu-07f334d89d47cba59f8f47fdc8f5983234487801.tar.xz
qemu-07f334d89d47cba59f8f47fdc8f5983234487801.zip
hw/char: Add Shakti UART emulation
This is the initial implementation of Shakti UART. Signed-off-by: Vijai Kumar K <vijai@behindbytes.com> Reviewed-by: Alistair Francis <alistair.francis@wdc.com> Message-id: 20210401181457.73039-4-vijai@behindbytes.com Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Diffstat (limited to 'hw/char/meson.build')
-rw-r--r--hw/char/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/char/meson.build b/hw/char/meson.build
index da5bb8b762..014833dded 100644
--- a/hw/char/meson.build
+++ b/hw/char/meson.build
@@ -19,6 +19,7 @@ softmmu_ss.add(when: 'CONFIG_SERIAL', if_true: files('serial.c'))
softmmu_ss.add(when: 'CONFIG_SERIAL_ISA', if_true: files('serial-isa.c'))
softmmu_ss.add(when: 'CONFIG_SERIAL_PCI', if_true: files('serial-pci.c'))
softmmu_ss.add(when: 'CONFIG_SERIAL_PCI_MULTI', if_true: files('serial-pci-multi.c'))
+softmmu_ss.add(when: 'CONFIG_SHAKTI', if_true: files('shakti_uart.c'))
softmmu_ss.add(when: 'CONFIG_VIRTIO_SERIAL', if_true: files('virtio-console.c'))
softmmu_ss.add(when: 'CONFIG_XEN', if_true: files('xen_console.c'))
softmmu_ss.add(when: 'CONFIG_XILINX', if_true: files('xilinx_uartlite.c'))