summaryrefslogtreecommitdiffstats
path: root/hw/char/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-02-21 19:52:29 +0100
committerPhilippe Mathieu-Daudé2021-03-06 16:18:42 +0100
commit7ae5c8bb6e57b08927a0f9ecae610abda0484ec6 (patch)
tree97d9c3b9e081a387c080bcdb1a07cceaa472dd2d /hw/char/meson.build
parenthw/intc: Introduce SH_INTC Kconfig entry (diff)
downloadqemu-7ae5c8bb6e57b08927a0f9ecae610abda0484ec6.tar.gz
qemu-7ae5c8bb6e57b08927a0f9ecae610abda0484ec6.tar.xz
qemu-7ae5c8bb6e57b08927a0f9ecae610abda0484ec6.zip
hw/char: Introduce SH_SCI Kconfig entry
We want to be able to use the 'SH4' config for architecture specific features. Add more fine-grained selection by adding a CONFIG_SH_SCI selector for the SH4 serial controller. Add the missing MAINTAINERS entries. Suggested-by: Peter Maydell <peter.maydell@linaro.org> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Acked-by: Paolo Bonzini <pbonzini@redhat.com> Message-Id: <20210222141514.2646278-5-f4bug@amsat.org>
Diffstat (limited to 'hw/char/meson.build')
-rw-r--r--hw/char/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/char/meson.build b/hw/char/meson.build
index 196ac91fa2..afe9a0af88 100644
--- a/hw/char/meson.build
+++ b/hw/char/meson.build
@@ -31,7 +31,7 @@ softmmu_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_uart.c'))
softmmu_ss.add(when: 'CONFIG_RASPI', if_true: files('bcm2835_aux.c'))
softmmu_ss.add(when: 'CONFIG_RENESAS_SCI', if_true: files('renesas_sci.c'))
softmmu_ss.add(when: 'CONFIG_SIFIVE_UART', if_true: files('sifive_uart.c'))
-softmmu_ss.add(when: 'CONFIG_SH4', if_true: files('sh_serial.c'))
+softmmu_ss.add(when: 'CONFIG_SH_SCI', if_true: files('sh_serial.c'))
softmmu_ss.add(when: 'CONFIG_STM32F2XX_USART', if_true: files('stm32f2xx_usart.c'))
softmmu_ss.add(when: 'CONFIG_MCHP_PFSOC_MMUART', if_true: files('mchp_pfsoc_mmuart.c'))