summaryrefslogtreecommitdiffstats
path: root/hw/char/meson.build
diff options
context:
space:
mode:
authorLaurent Vivier2021-03-12 22:41:41 +0100
committerLaurent Vivier2021-03-15 21:02:03 +0100
commit8c6df16ff6080365642b0583514dd03d6a7729d6 (patch)
tree618d99f863c80a6c207369230ec71a06521d1247 /hw/char/meson.build
parentMerge remote-tracking branch 'remotes/philmd/tags/avr-20210315' into staging (diff)
downloadqemu-8c6df16ff6080365642b0583514dd03d6a7729d6.tar.gz
qemu-8c6df16ff6080365642b0583514dd03d6a7729d6.tar.xz
qemu-8c6df16ff6080365642b0583514dd03d6a7729d6.zip
hw/char: add goldfish-tty
Implement the goldfish tty device as defined in https://android.googlesource.com/platform/external/qemu/+/master/docs/GOLDFISH-VIRTUAL-HARDWARE.TXT and based on the kernel driver code: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/tty/goldfish.c Signed-off-by: Laurent Vivier <laurent@vivier.eu> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Tested-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210312214145.2936082-2-laurent@vivier.eu>
Diffstat (limited to 'hw/char/meson.build')
-rw-r--r--hw/char/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/hw/char/meson.build b/hw/char/meson.build
index 7ba38dbd96..da5bb8b762 100644
--- a/hw/char/meson.build
+++ b/hw/char/meson.build
@@ -39,3 +39,5 @@ specific_ss.add(when: 'CONFIG_HTIF', if_true: files('riscv_htif.c'))
specific_ss.add(when: 'CONFIG_TERMINAL3270', if_true: files('terminal3270.c'))
specific_ss.add(when: 'CONFIG_VIRTIO', if_true: files('virtio-serial-bus.c'))
specific_ss.add(when: 'CONFIG_PSERIES', if_true: files('spapr_vty.c'))
+
+specific_ss.add(when: 'CONFIG_GOLDFISH_TTY', if_true: files('goldfish_tty.c'))