summaryrefslogtreecommitdiffstats
path: root/hw/display/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann2020-10-23 08:46:18 +0200
committerGerd Hoffmann2020-10-29 06:37:24 +0100
commit1e1f9c20bc0bdd4cf11cfe5057465d484b611858 (patch)
tree42ff7a9ff829f3184e973e43fbfee297bd169f0a /hw/display/meson.build
parentvirtio-gpu: add virtio-gpu-pci module (diff)
downloadqemu-1e1f9c20bc0bdd4cf11cfe5057465d484b611858.tar.gz
qemu-1e1f9c20bc0bdd4cf11cfe5057465d484b611858.tar.xz
qemu-1e1f9c20bc0bdd4cf11cfe5057465d484b611858.zip
virtio-gpu: add virtio-vga module
Build virtio-gpu vga devices modular. Must be a separate module because not all qemu softmmu variants come with VGA support. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-id: 20201023064618.21409-3-kraxel@redhat.com
Diffstat (limited to 'hw/display/meson.build')
-rw-r--r--hw/display/meson.build10
1 files changed, 8 insertions, 2 deletions
diff --git a/hw/display/meson.build b/hw/display/meson.build
index 6699353713..11ea2895c5 100644
--- a/hw/display/meson.build
+++ b/hw/display/meson.build
@@ -71,8 +71,14 @@ if config_all_devices.has_key('CONFIG_VIRTIO_PCI')
hw_display_modules += {'virtio-gpu-pci': virtio_gpu_pci_ss}
endif
-softmmu_ss.add(when: 'CONFIG_VIRTIO_VGA', if_true: files('virtio-vga.c'))
-softmmu_ss.add(when: 'CONFIG_VHOST_USER_VGA', if_true: files('vhost-user-vga.c'))
+if config_all_devices.has_key('CONFIG_VIRTIO_VGA')
+ virtio_vga_ss = ss.source_set()
+ virtio_vga_ss.add(when: 'CONFIG_VIRTIO_VGA',
+ if_true: [files('virtio-vga.c'), pixman])
+ virtio_vga_ss.add(when: 'CONFIG_VHOST_USER_VGA',
+ if_true: files('vhost-user-vga.c'))
+ hw_display_modules += {'virtio-vga': virtio_vga_ss}
+endif
specific_ss.add(when: [x11, opengl, 'CONFIG_MILKYMIST_TMU2'], if_true: files('milkymist-tmu2.c'))
specific_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_lcdc.c'))