summaryrefslogtreecommitdiffstats
path: root/hw/dma/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-01-31 19:44:46 +0100
committerPeter Maydell2021-02-03 11:15:50 +0100
commit6bfaec73a116e88c28ea91b10bc2a472aefcf957 (patch)
tree80236bf796b1cbd1738754869d1716d3b9cd5fce /hw/dma/meson.build
parenthw/arm/exynos4210: Add missing dependency on OR_IRQ (diff)
downloadqemu-6bfaec73a116e88c28ea91b10bc2a472aefcf957.tar.gz
qemu-6bfaec73a116e88c28ea91b10bc2a472aefcf957.tar.xz
qemu-6bfaec73a116e88c28ea91b10bc2a472aefcf957.zip
hw/arm/xlnx-versal: Versal SoC requires ZDMA
The Versal SoC instantiates the TYPE_XLNX_ZDMA object in versal_create_admas(). Introduce the XLNX_ZDMA configuration and select it to fix: $ qemu-system-aarch64 -M xlnx-versal-virt ... qemu-system-aarch64: missing object type 'xlnx.zdma' Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Alistair Francis <alistair.francis@wdc.com> Message-id: 20210131184449.382425-4-f4bug@amsat.org Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/dma/meson.build')
-rw-r--r--hw/dma/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/dma/meson.build b/hw/dma/meson.build
index b991d7698c..47b4a7cb47 100644
--- a/hw/dma/meson.build
+++ b/hw/dma/meson.build
@@ -9,7 +9,7 @@ softmmu_ss.add(when: 'CONFIG_ZYNQ_DEVCFG', if_true: files('xlnx-zynq-devcfg.c'))
softmmu_ss.add(when: 'CONFIG_ETRAXFS', if_true: files('etraxfs_dma.c'))
softmmu_ss.add(when: 'CONFIG_STP2000', if_true: files('sparc32_dma.c'))
softmmu_ss.add(when: 'CONFIG_XLNX_ZYNQMP_ARM', if_true: files('xlnx_dpdma.c'))
-softmmu_ss.add(when: 'CONFIG_XLNX_ZYNQMP_ARM', if_true: files('xlnx-zdma.c'))
+softmmu_ss.add(when: 'CONFIG_XLNX_ZDMA', if_true: files('xlnx-zdma.c'))
softmmu_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_dma.c', 'soc_dma.c'))
softmmu_ss.add(when: 'CONFIG_PXA2XX', if_true: files('pxa2xx_dma.c'))
softmmu_ss.add(when: 'CONFIG_RASPI', if_true: files('bcm2835_dma.c'))