summaryrefslogtreecommitdiffstats
path: root/hw/gpio/meson.build
diff options
context:
space:
mode:
authorHavard Skinnemoen2020-10-23 23:06:37 +0200
committerPeter Maydell2020-10-27 12:10:32 +0100
commit526dbbe087475599589ada4df70a337c09ae0f3f (patch)
treee952fde2b6f45bb9bdb891998a9fa71c16b0bb67 /hw/gpio/meson.build
parenthw/arm/npcm7xx: Add EHCI and OHCI controllers (diff)
downloadqemu-526dbbe087475599589ada4df70a337c09ae0f3f.tar.gz
qemu-526dbbe087475599589ada4df70a337c09ae0f3f.tar.xz
qemu-526dbbe087475599589ada4df70a337c09ae0f3f.zip
hw/gpio: Add GPIO model for Nuvoton NPCM7xx
The NPCM7xx chips have multiple GPIO controllers that are mostly identical except for some minor differences like the reset values of some registers. Each controller controls up to 32 pins. Each individual pin is modeled as a pair of unnamed GPIOs -- one for emitting the actual pin state, and one for driving the pin externally. Like the nRF51 GPIO controller, a gpio level may be negative, which means the pin is not driven, or floating. Reviewed-by: Tyrone Ting <kfting@nuvoton.com> Signed-off-by: Havard Skinnemoen <hskinnemoen@google.com> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
Diffstat (limited to 'hw/gpio/meson.build')
-rw-r--r--hw/gpio/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/gpio/meson.build b/hw/gpio/meson.build
index 86cae9a0f3..5c0a7d7b95 100644
--- a/hw/gpio/meson.build
+++ b/hw/gpio/meson.build
@@ -6,6 +6,7 @@ softmmu_ss.add(when: 'CONFIG_PUV3', if_true: files('puv3_gpio.c'))
softmmu_ss.add(when: 'CONFIG_ZAURUS', if_true: files('zaurus.c'))
softmmu_ss.add(when: 'CONFIG_IMX', if_true: files('imx_gpio.c'))
+softmmu_ss.add(when: 'CONFIG_NPCM7XX', if_true: files('npcm7xx_gpio.c'))
softmmu_ss.add(when: 'CONFIG_NRF51_SOC', if_true: files('nrf51_gpio.c'))
softmmu_ss.add(when: 'CONFIG_OMAP', if_true: files('omap_gpio.c'))
softmmu_ss.add(when: 'CONFIG_RASPI', if_true: files('bcm2835_gpio.c'))