summaryrefslogtreecommitdiffstats
path: root/hw/i386/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann2020-09-15 14:08:56 +0200
committerGerd Hoffmann2020-09-17 14:16:19 +0200
commit8045df14bccaeec39291c3d83fea2f638656b5d0 (patch)
treecc3062a912fd65a2ac4285bdb9e79b2c40e8e112 /hw/i386/meson.build
parentmicrovm: make virtio irq base runtime configurable (diff)
downloadqemu-8045df14bccaeec39291c3d83fea2f638656b5d0.tar.gz
qemu-8045df14bccaeec39291c3d83fea2f638656b5d0.tar.xz
qemu-8045df14bccaeec39291c3d83fea2f638656b5d0.zip
microvm/acpi: add minimal acpi support
$subject says all. Can be controlled using -M microvm,acpi=on/off. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Igor Mammedov <imammedo@redhat.com> Message-id: 20200915120909.20838-9-kraxel@redhat.com
Diffstat (limited to 'hw/i386/meson.build')
-rw-r--r--hw/i386/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/i386/meson.build b/hw/i386/meson.build
index 1a7d1a685d..e5d109f5c6 100644
--- a/hw/i386/meson.build
+++ b/hw/i386/meson.build
@@ -11,7 +11,7 @@ i386_ss.add(when: 'CONFIG_X86_IOMMU', if_true: files('x86-iommu.c'),
if_false: files('x86-iommu-stub.c'))
i386_ss.add(when: 'CONFIG_AMD_IOMMU', if_true: files('amd_iommu.c'))
i386_ss.add(when: 'CONFIG_I440FX', if_true: files('pc_piix.c'))
-i386_ss.add(when: 'CONFIG_MICROVM', if_true: files('microvm.c'))
+i386_ss.add(when: 'CONFIG_MICROVM', if_true: files('microvm.c', 'acpi-microvm.c'))
i386_ss.add(when: 'CONFIG_Q35', if_true: files('pc_q35.c'))
i386_ss.add(when: 'CONFIG_VMMOUSE', if_true: files('vmmouse.c'))
i386_ss.add(when: 'CONFIG_VMPORT', if_true: files('vmport.c'))