summaryrefslogtreecommitdiffstats
path: root/hw/mips/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-12-06 20:29:00 +0100
committerPhilippe Mathieu-Daudé2020-12-13 19:58:54 +0100
commit2fd9c5ad4449c862932b21e8f6b4573cc50b9ae8 (patch)
tree44ea62b782d76e76685ad82d98701a05ec4be8b0 /hw/mips/meson.build
parenttarget/mips: Introduce cpu_supports_isa() taking CPUMIPSState argument (diff)
downloadqemu-2fd9c5ad4449c862932b21e8f6b4573cc50b9ae8.tar.gz
qemu-2fd9c5ad4449c862932b21e8f6b4573cc50b9ae8.tar.xz
qemu-2fd9c5ad4449c862932b21e8f6b4573cc50b9ae8.zip
hw/mips: Move address translation helpers to target/mips/
Address translation is an architectural thing (not hardware related). Move the helpers from hw/ to target/. As physical address and KVM are specific to system mode emulation, restrict this file to softmmu, so it doesn't get compiled for user-mode emulation. Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201206233949.3783184-2-f4bug@amsat.org>
Diffstat (limited to 'hw/mips/meson.build')
-rw-r--r--hw/mips/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/hw/mips/meson.build b/hw/mips/meson.build
index bcdf96be69..77b4d8f365 100644
--- a/hw/mips/meson.build
+++ b/hw/mips/meson.build
@@ -1,5 +1,5 @@
mips_ss = ss.source_set()
-mips_ss.add(files('addr.c', 'mips_int.c'))
+mips_ss.add(files('mips_int.c'))
mips_ss.add(when: 'CONFIG_FULOONG', if_true: files('fuloong2e.c'))
mips_ss.add(when: 'CONFIG_JAZZ', if_true: files('jazz.c'))
mips_ss.add(when: 'CONFIG_MALTA', if_true: files('gt64xxx_pci.c', 'malta.c'))