summaryrefslogtreecommitdiffstats
path: root/hw/ppc/meson.build
diff options
context:
space:
mode:
authorDavid Gibson2020-04-08 07:10:03 +0200
committerDavid Gibson2021-02-08 06:57:38 +0100
commit6c8ebe30ea8055fce8b24730e970532b3c849fdb (patch)
tree177b5de9193d3ca1632d71a68696b8b11d24c676 /hw/ppc/meson.build
parentconfidential guest support: Update documentation (diff)
downloadqemu-6c8ebe30ea8055fce8b24730e970532b3c849fdb.tar.gz
qemu-6c8ebe30ea8055fce8b24730e970532b3c849fdb.tar.xz
qemu-6c8ebe30ea8055fce8b24730e970532b3c849fdb.zip
spapr: Add PEF based confidential guest support
Some upcoming POWER machines have a system called PEF (Protected Execution Facility) which uses a small ultravisor to allow guests to run in a way that they can't be eavesdropped by the hypervisor. The effect is roughly similar to AMD SEV, although the mechanisms are quite different. Most of the work of this is done between the guest, KVM and the ultravisor, with little need for involvement by qemu. However qemu does need to tell KVM to allow secure VMs. Because the availability of secure mode is a guest visible difference which depends on having the right hardware and firmware, we don't enable this by default. In order to run a secure guest you need to create a "pef-guest" object and set the confidential-guest-support property to point to it. Note that this just *allows* secure guests, the architecture of PEF is such that the guest still needs to talk to the ultravisor to enter secure mode. Qemu has no direct way of knowing if the guest is in secure mode, and certainly can't know until well after machine creation time. To start a PEF-capable guest, use the command line options: -object pef-guest,id=pef0 -machine confidential-guest-support=pef0 Signed-off-by: David Gibson <david@gibson.dropbear.id.au> Reviewed-by: Greg Kurz <groug@kaod.org>
Diffstat (limited to 'hw/ppc/meson.build')
-rw-r--r--hw/ppc/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/ppc/meson.build b/hw/ppc/meson.build
index ffa2ec37fa..218631c883 100644
--- a/hw/ppc/meson.build
+++ b/hw/ppc/meson.build
@@ -27,6 +27,7 @@ ppc_ss.add(when: 'CONFIG_PSERIES', if_true: files(
'spapr_nvdimm.c',
'spapr_rtas_ddw.c',
'spapr_numa.c',
+ 'pef.c',
))
ppc_ss.add(when: 'CONFIG_SPAPR_RNG', if_true: files('spapr_rng.c'))
ppc_ss.add(when: ['CONFIG_PSERIES', 'CONFIG_LINUX'], if_true: files(