summaryrefslogtreecommitdiffstats
path: root/hw/remote/meson.build
diff options
context:
space:
mode:
authorJagannathan Raman2021-01-29 17:46:12 +0100
committerStefan Hajnoczi2021-02-10 10:23:28 +0100
commitc7d80c7c1d9183fedd33fabd68190de51aab291d (patch)
tree6af3292171e6fe5afa7457b523ea2ceda72bacf4 /hw/remote/meson.build
parentmulti-process: Initialize message handler in remote device (diff)
downloadqemu-c7d80c7c1d9183fedd33fabd68190de51aab291d.tar.gz
qemu-c7d80c7c1d9183fedd33fabd68190de51aab291d.tar.xz
qemu-c7d80c7c1d9183fedd33fabd68190de51aab291d.zip
multi-process: Associate fd of a PCIDevice with its object
Associate the file descriptor for a PCIDevice in remote process with DeviceState object. Signed-off-by: Elena Ufimtseva <elena.ufimtseva@oracle.com> Signed-off-by: John G Johnson <john.g.johnson@oracle.com> Signed-off-by: Jagannathan Raman <jag.raman@oracle.com> Reviewed-by: Stefan Hajnoczi <stefanha@redhat.com> Message-id: f405a2ed5d7518b87bea7c59cfdf334d67e5ee51.1611938319.git.jag.raman@oracle.com Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
Diffstat (limited to 'hw/remote/meson.build')
-rw-r--r--hw/remote/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/remote/meson.build b/hw/remote/meson.build
index 9f5c57f35a..71d0a5689e 100644
--- a/hw/remote/meson.build
+++ b/hw/remote/meson.build
@@ -3,5 +3,6 @@ remote_ss = ss.source_set()
remote_ss.add(when: 'CONFIG_MULTIPROCESS', if_true: files('machine.c'))
remote_ss.add(when: 'CONFIG_MULTIPROCESS', if_true: files('mpqemu-link.c'))
remote_ss.add(when: 'CONFIG_MULTIPROCESS', if_true: files('message.c'))
+remote_ss.add(when: 'CONFIG_MULTIPROCESS', if_true: files('remote-obj.c'))
softmmu_ss.add_all(when: 'CONFIG_MULTIPROCESS', if_true: remote_ss)