summaryrefslogtreecommitdiffstats
path: root/hw/s390x/meson.build
diff options
context:
space:
mode:
authorMatthew Rosato2020-10-26 16:34:34 +0100
committerAlex Williamson2020-11-01 20:30:52 +0100
commitcd7498d07fbb20fa04790ff7ee168a8a8d01cb30 (patch)
treee0ca80da5259ea2faf8e45e729bcd3edf23c443e /hw/s390x/meson.build
parentvfio: Find DMA available capability (diff)
downloadqemu-cd7498d07fbb20fa04790ff7ee168a8a8d01cb30.tar.gz
qemu-cd7498d07fbb20fa04790ff7ee168a8a8d01cb30.tar.xz
qemu-cd7498d07fbb20fa04790ff7ee168a8a8d01cb30.zip
s390x/pci: Add routine to get the vfio dma available count
Create new files for separating out vfio-specific work for s390 pci. Add the first such routine, which issues VFIO_IOMMU_GET_INFO ioctl to collect the current dma available count. Signed-off-by: Matthew Rosato <mjrosato@linux.ibm.com> Reviewed-by: Cornelia Huck <cohuck@redhat.com> [aw: Fix non-Linux build with CONFIG_LINUX] Signed-off-by: Alex Williamson <alex.williamson@redhat.com>
Diffstat (limited to 'hw/s390x/meson.build')
-rw-r--r--hw/s390x/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/hw/s390x/meson.build b/hw/s390x/meson.build
index 948ceae7a7..f4663a8355 100644
--- a/hw/s390x/meson.build
+++ b/hw/s390x/meson.build
@@ -27,6 +27,7 @@ s390x_ss.add(when: 'CONFIG_KVM', if_true: files(
))
s390x_ss.add(when: 'CONFIG_S390_CCW_VIRTIO', if_true: files('s390-virtio-ccw.c'))
s390x_ss.add(when: 'CONFIG_TERMINAL3270', if_true: files('3270-ccw.c'))
+s390x_ss.add(when: 'CONFIG_LINUX', if_true: files('s390-pci-vfio.c'))
virtio_ss = ss.source_set()
virtio_ss.add(files('virtio-ccw.c'))