summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-17 22:31:05 +0200
committerPaolo Bonzini2020-08-21 12:30:08 +0200
commit04c6f1e798fc0f0f344e49b543a8334d9972d6c2 (patch)
tree710ffd61e5d395318f42f9cc151060539f3b9ba2 /meson.build
parentmeson: add remaining generated tcg trace helpers (diff)
downloadqemu-04c6f1e798fc0f0f344e49b543a8334d9972d6c2.tar.gz
qemu-04c6f1e798fc0f0f344e49b543a8334d9972d6c2.tar.xz
qemu-04c6f1e798fc0f0f344e49b543a8334d9972d6c2.zip
meson: add version.o
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4e9eb5da5c..feb3c8a30c 100644
--- a/meson.build
+++ b/meson.build
@@ -49,8 +49,14 @@ targetos = host_machine.system()
m = cc.find_library('m', required: false)
util = cc.find_library('util', required: false)
socket = []
+version_res = []
if targetos == 'windows'
socket = cc.find_library('ws2_32')
+
+ win = import('windows')
+ version_res = win.compile_resources('version.rc',
+ depend_files: files('pc-bios/qemu-nsis.ico'),
+ include_directories: include_directories('.'))
endif
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
link_args: config_host['GLIB_LIBS'].split())
@@ -235,7 +241,7 @@ libqemuutil = static_library('qemuutil',
sources: util_ss.sources() + stub_ss.sources() + genh,
dependencies: [util_ss.dependencies(), m, glib, socket])
qemuutil = declare_dependency(link_with: libqemuutil,
- sources: genh)
+ sources: genh + version_res)
summary_info = {}
summary_info += {'Install prefix': config_host['prefix']}