summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:55:54 +0200
committerPaolo Bonzini2020-10-12 17:50:19 +0200
commit064f8ee7aa6e7734f12cc1f3fbbcf61949006e0f (patch)
tree9d9e37c22a088b6351f18ebb77b372875c133075 /meson.build
parentMerge remote-tracking branch 'remotes/dgilbert/tags/pull-migration-20201012a'... (diff)
downloadqemu-064f8ee7aa6e7734f12cc1f3fbbcf61949006e0f.tar.gz
qemu-064f8ee7aa6e7734f12cc1f3fbbcf61949006e0f.tar.xz
qemu-064f8ee7aa6e7734f12cc1f3fbbcf61949006e0f.zip
meson.build: Add comments to clarify code organization
Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-2-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 17c89c87c6..68eaf8ce2f 100644
--- a/meson.build
+++ b/meson.build
@@ -1446,6 +1446,10 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
capture: true,
command: [undefsym, nm, '@INPUT@'])
+########################
+# Library dependencies #
+########################
+
block_ss = block_ss.apply(config_host, strict: false)
libblock = static_library('block', block_ss.sources() + genh,
dependencies: block_ss.dependencies(),
@@ -1465,6 +1469,10 @@ libqmp = static_library('qmp', qmp_ss.sources() + genh,
qmp = declare_dependency(link_whole: [libqmp])
+###########
+# Targets #
+###########
+
foreach m : block_mods + softmmu_mods
shared_module(m.name(),
name_prefix: '',