summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorCésar Belley2020-08-26 13:42:04 +0200
committerGerd Hoffmann2020-08-31 08:23:10 +0200
commit0a40bcb740aabf5e9504168dee039d5b9f242c41 (patch)
tree853d36955c6603f007f89389d6909c3633544e3a /meson.build
parenthw/usb: Add U2F key emulated mode (diff)
downloadqemu-0a40bcb740aabf5e9504168dee039d5b9f242c41.tar.gz
qemu-0a40bcb740aabf5e9504168dee039d5b9f242c41.tar.xz
qemu-0a40bcb740aabf5e9504168dee039d5b9f242c41.zip
meson: Add U2F key to meson
Signed-off-by: César Belley <cesar.belley@lse.epita.fr> Message-id: 20200826114209.28821-8-cesar.belley@lse.epita.fr [ fixes suggested by paolo ] Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 74f8ea0c2e..1e7aee85e3 100644
--- a/meson.build
+++ b/meson.build
@@ -377,6 +377,12 @@ if 'CONFIG_SMARTCARD' in config_host
cacard = declare_dependency(compile_args: config_host['SMARTCARD_CFLAGS'].split(),
link_args: config_host['SMARTCARD_LIBS'].split())
endif
+u2f = not_found
+if have_system
+ u2f = dependency('u2f-emu', required: get_option('u2f'),
+ method: 'pkg-config',
+ static: enable_static)
+endif
usbredir = not_found
if 'CONFIG_USB_REDIR' in config_host
usbredir = declare_dependency(compile_args: config_host['USB_REDIR_CFLAGS'].split(),
@@ -1375,6 +1381,7 @@ summary_info += {'spice support': config_host.has_key('CONFIG_SPICE')}
summary_info += {'rbd support': config_host.has_key('CONFIG_RBD')}
summary_info += {'xfsctl support': config_host.has_key('CONFIG_XFS')}
summary_info += {'smartcard support': config_host.has_key('CONFIG_SMARTCARD')}
+summary_info += {'U2F support': u2f.found()}
summary_info += {'libusb': config_host.has_key('CONFIG_USB_LIBUSB')}
summary_info += {'usb net redir': config_host.has_key('CONFIG_USB_REDIR')}
summary_info += {'OpenGL support': config_host.has_key('CONFIG_OPENGL')}