summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAlex Bennée2020-11-10 20:23:09 +0100
committerAlex Bennée2020-11-16 12:07:39 +0100
commit0c3e41d40828f78f182c6eb7d54624ce7b0c49f8 (patch)
tree39c44848f695694838656f4830303c2c6aadb7bd /meson.build
parentplugins: Fix two resource leaks in setup_socket() (diff)
downloadqemu-0c3e41d40828f78f182c6eb7d54624ce7b0c49f8.tar.gz
qemu-0c3e41d40828f78f182c6eb7d54624ce7b0c49f8.tar.xz
qemu-0c3e41d40828f78f182c6eb7d54624ce7b0c49f8.zip
meson.build: fix building of Xen support for aarch64
Xen is supported on ARM although weirdly using the i386-softmmu model. Checking based on the host CPU meant we never enabled Xen support. It would be nice to enable CONFIG_XEN for aarch64-softmmu to make it not seem weird but that will require further build surgery. Fixes: 8a19980e3f ("configure: move accelerator logic to meson") Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Alex Bennée <alex.bennee@linaro.org> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Cc: Masami Hiramatsu <masami.hiramatsu@linaro.org> Cc: Stefano Stabellini <sstabellini@kernel.org> Cc: Anthony Perard <anthony.perard@citrix.com> Cc: Paul Durrant <paul@xen.org> Message-Id: <20201110192316.26397-4-alex.bennee@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 61d883bc07..132bc49782 100644
--- a/meson.build
+++ b/meson.build
@@ -74,10 +74,15 @@ else
endif
accelerator_targets = { 'CONFIG_KVM': kvm_targets }
+if cpu in ['x86', 'x86_64', 'arm', 'aarch64']
+ # i368 emulator provides xenpv machine type for multiple architectures
+ accelerator_targets += {
+ 'CONFIG_XEN': ['i386-softmmu', 'x86_64-softmmu'],
+ }
+endif
if cpu in ['x86', 'x86_64']
accelerator_targets += {
'CONFIG_HAX': ['i386-softmmu', 'x86_64-softmmu'],
- 'CONFIG_XEN': ['i386-softmmu', 'x86_64-softmmu'],
'CONFIG_HVF': ['x86_64-softmmu'],
'CONFIG_WHPX': ['i386-softmmu', 'x86_64-softmmu'],
}