summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authornia2021-10-13 15:54:17 +0200
committerPaolo Bonzini2021-11-19 10:13:44 +0100
commit0cc4965049d9792ffede8fc371b58193d6ecbb02 (patch)
tree2c27db71c7db55e8954c3df9c3eb2c2be7d4b23a /meson.build
parentmeson: fix botched compile check conversions (diff)
downloadqemu-0cc4965049d9792ffede8fc371b58193d6ecbb02.tar.gz
qemu-0cc4965049d9792ffede8fc371b58193d6ecbb02.tar.xz
qemu-0cc4965049d9792ffede8fc371b58193d6ecbb02.zip
nvmm: Fix support for stable version
NVMM user version 1 is the version being shipped with netbsd-9, which is the most recent stable branch of NetBSD. This makes it possible to use the NVMM accelerator on the most recent NetBSD release, 9.2, which lacks nvmm_cpu_stop. (CC'ing maintainers) Signed-off-by: Nia Alarie <nia@NetBSD.org> Reviewed-by: Kamil Rytarowski <kamil@netbsd.org> Message-Id: <YWblCe2J8GwCaV9U@homeworld.netbsd.org> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 93a5e50a16..582f356209 100644
--- a/meson.build
+++ b/meson.build
@@ -323,9 +323,7 @@ if not get_option('hax').disabled()
endif
endif
if targetos == 'netbsd'
- if cc.has_header_symbol('nvmm.h', 'nvmm_cpu_stop', required: get_option('nvmm'))
- nvmm = cc.find_library('nvmm', required: get_option('nvmm'))
- endif
+ nvmm = cc.find_library('nvmm', required: get_option('nvmm'))
if nvmm.found()
accelerators += 'CONFIG_NVMM'
endif