summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-11-30 14:07:48 +0100
committerPaolo Bonzini2021-01-02 21:03:36 +0100
commit0dbce6efb5ff2e7113734d3a0cabbf87fc56feec (patch)
tree161c7fe63efb7b25dab1132760fdb9dfde2c315b /meson.build
parentMakefile: add dummy target for build.ninja dependencies (diff)
downloadqemu-0dbce6efb5ff2e7113734d3a0cabbf87fc56feec.tar.gz
qemu-0dbce6efb5ff2e7113734d3a0cabbf87fc56feec.tar.xz
qemu-0dbce6efb5ff2e7113734d3a0cabbf87fc56feec.zip
meson: fix detection of curses with pkgconfig
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index ada35d56e1..022272f4cf 100644
--- a/meson.build
+++ b/meson.build
@@ -504,16 +504,16 @@ if have_system and not get_option('curses').disabled()
endif
endforeach
msg = get_option('curses').enabled() ? 'curses library not found' : ''
+ curses_compile_args = ['-DNCURSES_WIDECHAR']
if curses.found()
- if cc.links(curses_test, dependencies: [curses])
- curses = declare_dependency(compile_args: '-DNCURSES_WIDECHAR', dependencies: [curses])
+ if cc.links(curses_test, args: curses_compile_args, dependencies: [curses])
+ curses = declare_dependency(compile_args: curses_compile_args, dependencies: [curses])
else
msg = 'curses package not usable'
curses = not_found
endif
endif
if not curses.found()
- curses_compile_args = ['-DNCURSES_WIDECHAR']
has_curses_h = cc.has_header('curses.h', args: curses_compile_args)
if targetos != 'windows' and not has_curses_h
message('Trying with /usr/include/ncursesw')