summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2020-11-25 11:06:37 +0100
committerMichael S. Tsirkin2020-12-08 19:48:58 +0100
commit0df750e9d3a5fea5e19f4750582121c9293a9d71 (patch)
treed1333e36fdf7bc7d8e5dbbbc8c7398748d6a2756 /meson.build
parentlibvhost-user: drop qemu/osdep.h dependency (diff)
downloadqemu-0df750e9d3a5fea5e19f4750582121c9293a9d71.tar.gz
qemu-0df750e9d3a5fea5e19f4750582121c9293a9d71.tar.xz
qemu-0df750e9d3a5fea5e19f4750582121c9293a9d71.zip
libvhost-user: make it a meson subproject
By making libvhost-user a subproject, check it builds standalone (without the global QEMU cflags etc). Note that the library still relies on QEMU include/qemu/atomic.h and linux_headers/. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20201125100640.366523-6-marcandre.lureau@redhat.com> Reviewed-by: Michael S. Tsirkin <mst@redhat.com> Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index e3386196ba..732b29a1f3 100644
--- a/meson.build
+++ b/meson.build
@@ -1475,7 +1475,12 @@ trace_events_subdirs += [
'util',
]
-subdir('contrib/libvhost-user')
+vhost_user = not_found
+if 'CONFIG_VHOST_USER' in config_host
+ libvhost_user = subproject('libvhost-user')
+ vhost_user = libvhost_user.get_variable('vhost_user_dep')
+endif
+
subdir('qapi')
subdir('qobject')
subdir('stubs')