summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorRichard Henderson2021-12-31 06:25:11 +0100
committerRichard Henderson2021-12-31 06:37:35 +0100
commit0e3ed77de51fab46d1ade0bee102e68fa376fbd8 (patch)
tree38d491640848e981c09bfaa6cdacbdb98ba428f1 /meson.build
parentMerge tag 'memory-api-20211231' of https://github.com/philmd/qemu into staging (diff)
downloadqemu-0e3ed77de51fab46d1ade0bee102e68fa376fbd8.tar.gz
qemu-0e3ed77de51fab46d1ade0bee102e68fa376fbd8.tar.xz
qemu-0e3ed77de51fab46d1ade0bee102e68fa376fbd8.zip
meson: Unify mips and mips64 in host_arch
Fixes the build on a mips64 host. Prior to the break, we identified the arch via the __mips__ define; afterward we use meson's host_machine.cpu_family(). Restore the previous combination. Fixes: 823eb013452e ("configure, meson: move ARCH to meson.build") Reported-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 886f0a9343..53065e96ec 100644
--- a/meson.build
+++ b/meson.build
@@ -74,6 +74,8 @@ if cpu not in supported_cpus
host_arch = 'unknown'
elif cpu == 'x86'
host_arch = 'i386'
+elif cpu == 'mips64'
+ host_arch = 'mips'
else
host_arch = cpu
endif