summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-08-20 10:29:52 +0200
committerPaolo Bonzini2020-08-21 12:30:41 +0200
commit10e1d2636dc607eaf0aa3f534e834cd2bf018750 (patch)
tree50aebe2d60b167fbe35ed57e2403148a91f36331 /meson.build
parentconfigure: place compatibility symlinks in target directories (diff)
downloadqemu-10e1d2636dc607eaf0aa3f534e834cd2bf018750.tar.gz
qemu-10e1d2636dc607eaf0aa3f534e834cd2bf018750.tar.xz
qemu-10e1d2636dc607eaf0aa3f534e834cd2bf018750.zip
meson: convert systemtap files
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9db1b7b705..108706f7e5 100644
--- a/meson.build
+++ b/meson.build
@@ -958,6 +958,30 @@ foreach target : target_dirs
link_depends: [block_syms, qemu_syms] + exe.get('link_depends', []),
link_args: link_args,
gui_app: exe['gui'])
+
+ if 'CONFIG_TRACE_SYSTEMTAP' in config_host
+ foreach stp: [
+ {'ext': '.stp-build', 'fmt': 'stap', 'bin': meson.current_build_dir() / exe_name, 'install': false},
+ {'ext': '.stp', 'fmt': 'stap', 'bin': get_option('prefix') / get_option('bindir') / exe_name, 'install': true},
+ {'ext': '-simpletrace.stp', 'fmt': 'simpletrace-stap', 'bin': '', 'install': true},
+ {'ext': '-log.stp', 'fmt': 'log-stap', 'bin': '', 'install': true},
+ ]
+ custom_target(exe_name + stp['ext'],
+ input: trace_events_all,
+ output: exe_name + stp['ext'],
+ capture: true,
+ install: stp['install'],
+ install_dir: config_host['qemu_datadir'] / '../systemtap/tapset',
+ command: [
+ tracetool, '--group=all', '--format=' + stp['fmt'],
+ '--binary=' + stp['bin'],
+ '--target-name=' + target_name,
+ '--target-type=' + target_type,
+ '--probe-prefix=qemu.' + target_type + '.' + target_name,
+ '@INPUT@',
+ ])
+ endforeach
+ endif
endforeach
endforeach