summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-06-03 11:15:26 +0200
committerPaolo Bonzini2021-06-25 10:54:12 +0200
commit18f31e60c7f02e2fdeebce344b2f95c65cbf2bef (patch)
treed6a404a2d8351d83e5e257c97573564f9ed7540e /meson.build
parentconfigure, meson: convert libcacard detection to meson (diff)
downloadqemu-18f31e60c7f02e2fdeebce344b2f95c65cbf2bef.tar.gz
qemu-18f31e60c7f02e2fdeebce344b2f95c65cbf2bef.tar.xz
qemu-18f31e60c7f02e2fdeebce344b2f95c65cbf2bef.zip
configure, meson: convert libusbredir detection to meson
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index afcfcb8c57..64e23175ab 100644
--- a/meson.build
+++ b/meson.build
@@ -988,9 +988,10 @@ if have_system
kwargs: static_kwargs)
endif
usbredir = not_found
-if 'CONFIG_USB_REDIR' in config_host
- usbredir = declare_dependency(compile_args: config_host['USB_REDIR_CFLAGS'].split(),
- link_args: config_host['USB_REDIR_LIBS'].split())
+if not get_option('usb_redir').auto() or have_system
+ usbredir = dependency('libusbredirparser-0.5', required: get_option('usb_redir'),
+ version: '>=0.6', method: 'pkg-config',
+ kwargs: static_kwargs)
endif
libusb = not_found
if not get_option('libusb').auto() or have_system
@@ -2785,7 +2786,7 @@ summary_info += {'xfsctl support': config_host.has_key('CONFIG_XFS')}
summary_info += {'smartcard support': cacard.found()}
summary_info += {'U2F support': u2f.found()}
summary_info += {'libusb': libusb.found()}
-summary_info += {'usb net redir': config_host.has_key('CONFIG_USB_REDIR')}
+summary_info += {'usb net redir': usbredir.found()}
summary_info += {'OpenGL support': config_host.has_key('CONFIG_OPENGL')}
summary_info += {'GBM': config_host.has_key('CONFIG_GBM')}
summary_info += {'libiscsi support': libiscsi.found()}