summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-26 09:24:11 +0200
committerPaolo Bonzini2020-08-27 18:52:30 +0200
commit1917ec6d564d3fae404adedcbb6e8a724fba8894 (patch)
tree8ac3bbd1b5ca41d3a537d6d174df52df62783787 /meson.build
parentconfigure: add --ninja option (diff)
downloadqemu-1917ec6d564d3fae404adedcbb6e8a724fba8894.tar.gz
qemu-1917ec6d564d3fae404adedcbb6e8a724fba8894.tar.xz
qemu-1917ec6d564d3fae404adedcbb6e8a724fba8894.zip
meson: cleanup xkbcommon detection
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 5 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index a3baa2dbf0..90128616e5 100644
--- a/meson.build
+++ b/meson.build
@@ -165,10 +165,11 @@ libcap_ng = not_found
if 'CONFIG_LIBCAP_NG' in config_host
libcap_ng = declare_dependency(link_args: config_host['LIBCAP_NG_LIBS'].split())
endif
-xkbcommon = dependency('xkbcommon', required: get_option('xkbcommon'), static: enable_static,
- include_type: 'system')
-if xkbcommon.found()
- xkbcommon = declare_dependency(dependencies: xkbcommon)
+if get_option('xkbcommon').auto() and not have_system and not have_tools
+ xkbcommon = not_found
+else
+ xkbcommon = dependency('xkbcommon', required: get_option('xkbcommon'),
+ static: enable_static)
endif
slirp = not_found
if config_host.has_key('CONFIG_SLIRP')
@@ -1078,9 +1079,6 @@ endif
# Don't build qemu-keymap if xkbcommon is not explicitly enabled
# when we don't build tools or system
-if get_option('xkbcommon').auto() and not have_system and not have_tools
- xkbcommon = not_found
-endif
if xkbcommon.found()
# used for the update-keymaps target, so include rules even if !have_tools
qemu_keymap = executable('qemu-keymap', files('qemu-keymap.c', 'ui/input-keymap.c') + genh,