summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2022-06-23 19:49:41 +0200
committerThomas Huth2022-07-05 10:15:49 +0200
commit1ec8c2c01ed9c1b2bc8a273c7045e179f90013bc (patch)
tree932f68d9ca1669df9b66bb7e502f30d4c1dfd2d9 /meson.build
parentpo: add ukrainian translation (diff)
downloadqemu-1ec8c2c01ed9c1b2bc8a273c7045e179f90013bc.tar.gz
qemu-1ec8c2c01ed9c1b2bc8a273c7045e179f90013bc.tar.xz
qemu-1ec8c2c01ed9c1b2bc8a273c7045e179f90013bc.zip
meson.build: Require a recent version of libpng
According to https://gitlab.com/qemu-project/qemu/-/issues/1080#note_998088246 QEMU does not compile with older versions of libpng, so we should check for a good version in meson.build. According to repology.org, our supported host target operating systems ship these versions: Fedora 35: 1.6.37 CentOS 8 (RHEL-8): 1.6.34 Debian 11: 1.6.37 OpenSUSE Leap 15.3: 1.6.34 Ubuntu LTS 20.04: 1.6.37 FreeBSD Ports: 1.6.37 NetBSD pkgsrc: 1.6.37 OpenBSD Ports: 1.6.37 Homebrew: 1.6.37 MSYS2 mingw: 1.6.37 So it seem reasonable to require at least libpng version 1.6.34 for our builds. Resolves: https://gitlab.com/qemu-project/qemu/-/issues/1080 Message-Id: <20220623174941.531196-1-thuth@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f34ae9a5f8..bc5569ace1 100644
--- a/meson.build
+++ b/meson.build
@@ -1209,7 +1209,7 @@ if gtkx11.found()
endif
png = not_found
if get_option('png').allowed() and have_system
- png = dependency('libpng', required: get_option('png'),
+ png = dependency('libpng', version: '>=1.6.34', required: get_option('png'),
method: 'pkg-config', kwargs: static_kwargs)
endif
vnc = not_found