summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-11-17 13:32:34 +0100
committerPaolo Bonzini2021-01-06 10:21:20 +0100
commit241611eab28c43b1e1dc87cbc9f97545b40eec1a (patch)
treee64d43797d124035991c8756468470296cde23f6 /meson.build
parentlzo: convert to meson (diff)
downloadqemu-241611eab28c43b1e1dc87cbc9f97545b40eec1a.tar.gz
qemu-241611eab28c43b1e1dc87cbc9f97545b40eec1a.tar.xz
qemu-241611eab28c43b1e1dc87cbc9f97545b40eec1a.zip
snappy: convert to meson
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build20
1 files changed, 17 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 34683d5030..8861434721 100644
--- a/meson.build
+++ b/meson.build
@@ -745,9 +745,22 @@ if get_option('vnc').enabled()
compile_args: '-DSTRUCT_IOVEC_DEFINED')
endif
endif
+
snappy = not_found
-if 'CONFIG_SNAPPY' in config_host
- snappy = declare_dependency(link_args: config_host['SNAPPY_LIBS'].split())
+if not get_option('snappy').auto() or have_system
+ snappy = cc.find_library('snappy', has_headers: ['snappy-c.h'],
+ required: get_option('snappy'),
+ static: enable_static)
+endif
+if snappy.found() and not cc.links('''
+ #include <snappy-c.h>
+ int main(void) { snappy_max_compressed_length(4096); return 0; }''', dependencies: snappy)
+ snappy = not_found
+ if get_option('snappy').enabled()
+ error('could not link libsnappy')
+ else
+ warning('could not link libsnappy, disabling')
+ endif
endif
lzo = not_found
@@ -970,6 +983,7 @@ config_host_data.set('CONFIG_LIBNFS', libnfs.found())
config_host_data.set('CONFIG_RBD', rbd.found())
config_host_data.set('CONFIG_SDL', sdl.found())
config_host_data.set('CONFIG_SDL_IMAGE', sdl_image.found())
+config_host_data.set('CONFIG_SNAPPY', snappy.found())
config_host_data.set('CONFIG_VHOST_USER_BLK_SERVER', have_vhost_user_blk_server)
config_host_data.set('CONFIG_VNC', vnc.found())
config_host_data.set('CONFIG_VNC_JPEG', jpeg.found())
@@ -2352,7 +2366,7 @@ summary_info += {'libssh support': config_host.has_key('CONFIG_LIBSSH')}
summary_info += {'QOM debugging': config_host.has_key('CONFIG_QOM_CAST_DEBUG')}
summary_info += {'Live block migration': config_host.has_key('CONFIG_LIVE_BLOCK_MIGRATION')}
summary_info += {'lzo support': lzo.found()}
-summary_info += {'snappy support': config_host.has_key('CONFIG_SNAPPY')}
+summary_info += {'snappy support': snappy.found()}
summary_info += {'bzip2 support': libbzip2.found()}
summary_info += {'lzfse support': config_host.has_key('CONFIG_LZFSE')}
summary_info += {'zstd support': config_host.has_key('CONFIG_ZSTD')}