summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorStefan Weil2020-11-25 20:18:33 +0100
committerPaolo Bonzini2020-11-26 15:20:48 +0100
commit24bdcc9608fad3dce2bcf3362722493f1ba0f3eb (patch)
tree8448340d0cba72259067df41b25296fd4a32328a /meson.build
parenttests/docker, tests/vm: remove setuptools from images (diff)
downloadqemu-24bdcc9608fad3dce2bcf3362722493f1ba0f3eb.tar.gz
qemu-24bdcc9608fad3dce2bcf3362722493f1ba0f3eb.tar.xz
qemu-24bdcc9608fad3dce2bcf3362722493f1ba0f3eb.zip
nsis: Fix build for 64 bit installer
Pass cpu instead of cpu_family to the NSIS installer script. That script checks for "x86_64" which is the cpu value, while cpu_family is "x86". Signed-off-by: Stefan Weil <sw@weilnetz.de> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20201125191833.964753-1-sw@weilnetz.de> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 360623ece9..e3386196ba 100644
--- a/meson.build
+++ b/meson.build
@@ -1955,7 +1955,7 @@ if host_machine.system() == 'windows'
'@OUTPUT@',
get_option('prefix'),
meson.current_source_dir(),
- host_machine.cpu_family(),
+ host_machine.cpu(),
'--',
'-DDISPLAYVERSION=' + meson.project_version(),
]