summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2019-07-29 15:40:07 +0200
committerPaolo Bonzini2020-08-21 12:30:19 +0200
commit2634733c6bfcb803a6b8f107a8ed1f3c598b0a47 (patch)
tree40f1ef0b450be1c1bb1c955194d408e16246e7e0 /meson.build
parentconfigure, Makefile; remove TOOLS and HELPERS-y variable (diff)
downloadqemu-2634733c6bfcb803a6b8f107a8ed1f3c598b0a47.tar.gz
qemu-2634733c6bfcb803a6b8f107a8ed1f3c598b0a47.tar.xz
qemu-2634733c6bfcb803a6b8f107a8ed1f3c598b0a47.zip
meson: convert chardev directory to Meson (emulator part)
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3a8cf11edc..d3b74868e2 100644
--- a/meson.build
+++ b/meson.build
@@ -147,6 +147,11 @@ if 'CONFIG_XKBCOMMON' in config_host
xkbcommon = declare_dependency(compile_args: config_host['XKBCOMMON_CFLAGS'].split(),
link_args: config_host['XKBCOMMON_LIBS'].split())
endif
+spice = not_found
+if 'CONFIG_SPICE' in config_host
+ spice = declare_dependency(compile_args: config_host['SPICE_CFLAGS'].split(),
+ link_args: config_host['SPICE_LIBS'].split())
+endif
rt = cc.find_library('rt', required: false)
libmpathpersist = not_found
if config_host.has_key('CONFIG_MPATH')
@@ -181,6 +186,15 @@ libudev = not_found
if 'CONFIG_LIBUDEV' in config_host
libudev = declare_dependency(link_args: config_host['LIBUDEV_LIBS'].split())
endif
+brlapi = not_found
+if 'CONFIG_BRLAPI' in config_host
+ brlapi = declare_dependency(link_args: config_host['BRLAPI_LIBS'].split())
+endif
+sdl = not_found
+if 'CONFIG_SDL' in config_host
+ sdl = declare_dependency(compile_args: config_host['SDL_CFLAGS'].split(),
+ link_args: config_host['SDL_LIBS'].split())
+endif
rbd = not_found
if 'CONFIG_RBD' in config_host
rbd = declare_dependency(link_args: config_host['RBD_LIBS'].split())