summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2020-11-18 18:10:48 +0100
committerLaurent Vivier2020-12-13 23:56:16 +0100
commit2802d91d515f3e51a8b3515a35e79c2c676da9e5 (patch)
treecffc49f195f73fcdfbce316e75f5c4acb9768cee /meson.build
parentconfigure: Remove the obsolete check for ifaddrs.h (diff)
downloadqemu-2802d91d515f3e51a8b3515a35e79c2c676da9e5.tar.gz
qemu-2802d91d515f3e51a8b3515a35e79c2c676da9e5.tar.xz
qemu-2802d91d515f3e51a8b3515a35e79c2c676da9e5.zip
configure / meson: Move check for pty.h to meson.build
This check can be done in a much shorter way in meson.build Signed-off-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201118171052.308191-3-thuth@redhat.com> Signed-off-by: Laurent Vivier <laurent@vivier.eu>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f344b25955..ef053c9837 100644
--- a/meson.build
+++ b/meson.build
@@ -836,6 +836,7 @@ config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0]
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])
config_host_data.set('QEMU_VERSION_MICRO', meson.project_version().split('.')[2])
+config_host_data.set('HAVE_PTY_H', cc.has_header('pty.h'))
config_host_data.set('HAVE_SYS_IOCCOM_H', cc.has_header('sys/ioccom.h'))
ignored = ['CONFIG_QEMU_INTERP_PREFIX'] # actually per-target