summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-08-17 11:55:58 +0200
committerPaolo Bonzini2020-08-21 12:30:33 +0200
commit2c44220d055d12142f27cf513848f17d6007ae35 (patch)
tree72593b21d3f6e20a325be46bfc05b69457e14244 /meson.build
parentmeson: convert hw/9pfs, cleanup (diff)
downloadqemu-2c44220d055d12142f27cf513848f17d6007ae35.tar.gz
qemu-2c44220d055d12142f27cf513848f17d6007ae35.tar.xz
qemu-2c44220d055d12142f27cf513848f17d6007ae35.zip
meson: convert hw/arch*
Each architecture's sourceset is placed in an hw_arch dictionary, and picked up from there when building the per-emulator static_library. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index ec958ba2af..5c9f66d2a7 100644
--- a/meson.build
+++ b/meson.build
@@ -787,6 +787,10 @@ foreach target : target_dirs
if target.endswith('-softmmu')
qemu_target_name = 'qemu-system-' + target_name
target_type='system'
+ hw_dir = target_name == 'sparc64' ? 'sparc64' : arch
+ hw = hw_arch[hw_dir].apply(config_target, strict: false)
+ arch_srcs += hw.sources()
+
arch_srcs += config_devices_h[target]
else
target_type='user'