summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-04-20 17:33:46 +0200
committerPaolo Bonzini2022-04-28 08:52:22 +0200
commit2cb2f5804c26a767f29eb032aebf9d063d9f0ced (patch)
treef51569252613e68cd88ccf250598c0f3c95a6d2b /meson.build
parentmeson: remove CONFIG_XEN_PCI_PASSTHROUGH from config-target.h (diff)
downloadqemu-2cb2f5804c26a767f29eb032aebf9d063d9f0ced.tar.gz
qemu-2cb2f5804c26a767f29eb032aebf9d063d9f0ced.tar.xz
qemu-2cb2f5804c26a767f29eb032aebf9d063d9f0ced.zip
meson, configure: move --enable-module-upgrades to meson
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 6 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ab1ac9b959..1fe7d257ff 100644
--- a/meson.build
+++ b/meson.build
@@ -1550,6 +1550,11 @@ endif
config_host_data.set('HOST_' + host_arch.to_upper(), 1)
+if get_option('module_upgrades') and not enable_modules
+ error('Cannot enable module-upgrades as modules are not enabled')
+endif
+config_host_data.set('CONFIG_MODULE_UPGRADES', get_option('module_upgrades'))
+
config_host_data.set('CONFIG_ATTR', libattr.found())
config_host_data.set('CONFIG_BDRV_WHITELIST_TOOLS', get_option('block_drv_whitelist_in_tools'))
config_host_data.set('CONFIG_BRLAPI', brlapi.found())
@@ -3576,7 +3581,7 @@ summary_info += {'block layer': have_block}
summary_info += {'Install blobs': get_option('install_blobs')}
summary_info += {'module support': config_host.has_key('CONFIG_MODULES')}
if config_host.has_key('CONFIG_MODULES')
- summary_info += {'alternative module path': config_host.has_key('CONFIG_MODULE_UPGRADES')}
+ summary_info += {'alternative module path': get_option('module_upgrades')}
endif
summary_info += {'fuzzing support': get_option('fuzzing')}
if have_system