summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2020-08-28 13:07:33 +0200
committerPaolo Bonzini2020-09-08 11:43:16 +0200
commit3909def82a699e4d628c07df948b4dd2656610ea (patch)
treeea4be56ef56387c7463bf8c9b28a70f405d5e432 /meson.build
parenttests/migration/stress: remove unused exit_success (diff)
downloadqemu-3909def82a699e4d628c07df948b4dd2656610ea.tar.gz
qemu-3909def82a699e4d628c07df948b4dd2656610ea.tar.xz
qemu-3909def82a699e4d628c07df948b4dd2656610ea.zip
meson: fix migration/stress compilation with glibc>=2.30
gettid() was introduced with glibc 2.30. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-Id: <20200828110734.1638685-16-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f7cd2b6f73..3b73731bab 100644
--- a/meson.build
+++ b/meson.build
@@ -418,6 +418,8 @@ endif
keyutils = dependency('libkeyutils', required: false,
method: 'pkg-config', static: enable_static)
+has_gettid = cc.has_function('gettid')
+
# Create config-host.h
config_host_data.set('CONFIG_SDL', sdl.found())
@@ -428,6 +430,7 @@ config_host_data.set('CONFIG_VNC_PNG', png.found())
config_host_data.set('CONFIG_VNC_SASL', sasl.found())
config_host_data.set('CONFIG_XKBCOMMON', xkbcommon.found())
config_host_data.set('CONFIG_KEYUTILS', keyutils.found())
+config_host_data.set('CONFIG_GETTID', has_gettid)
config_host_data.set('QEMU_VERSION', '"@0@"'.format(meson.project_version()))
config_host_data.set('QEMU_VERSION_MAJOR', meson.project_version().split('.')[0])
config_host_data.set('QEMU_VERSION_MINOR', meson.project_version().split('.')[1])