summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-02-11 12:15:12 +0100
committerPaolo Bonzini2021-12-23 10:06:19 +0100
commit3d2f73ef75e25ba850aff4fcccb36d50137afd0f (patch)
tree419f11d8d2085b2f8f67a2bc2ddf070287ffd43e /meson.build
parentMerge tag 'pull-user-20211220' of https://gitlab.com/rth7680/qemu into staging (diff)
downloadqemu-3d2f73ef75e25ba850aff4fcccb36d50137afd0f.tar.gz
qemu-3d2f73ef75e25ba850aff4fcccb36d50137afd0f.tar.xz
qemu-3d2f73ef75e25ba850aff4fcccb36d50137afd0f.zip
build: use "meson test" as the test harness
"meson test" starting with version 0.57 is just as capable and easy to use as QEMU's own TAP driver. All existing options for "make check" work. The only required code change involves how to mark "slow" tests; they need to belong to an additional "slow" suite. The rules for .tap output are replaced by JUnit XML; GitLab is able to parse that output and present it in the CI pipeline report. Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f45ecf31bd..f0f1d5ba9d 100644
--- a/meson.build
+++ b/meson.build
@@ -1,8 +1,11 @@
project('qemu', ['c'], meson_version: '>=0.58.2',
default_options: ['warning_level=1', 'c_std=gnu11', 'cpp_std=gnu++11', 'b_colorout=auto',
- 'b_staticpic=false'],
+ 'b_staticpic=false', 'stdsplit=false'],
version: files('VERSION'))
+add_test_setup('quick', exclude_suites: 'slow', is_default: true)
+add_test_setup('slow', env: ['G_TEST_SLOW=1', 'SPEED=slow'])
+
not_found = dependency('', required: false)
keyval = import('keyval')
ss = import('sourceset')