summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLaurent Vivier2020-09-17 16:07:00 +0200
committerLaurent Vivier2020-09-23 19:07:03 +0200
commit3e8529dd8554d77467734db6f84b3619eeeb6895 (patch)
treed83cd34a8caf3bce036e9341d0315ae43a16650c /meson.build
parentvhost-vdpa: fix indentation in vdpa_ops (diff)
downloadqemu-3e8529dd8554d77467734db6f84b3619eeeb6895.tar.gz
qemu-3e8529dd8554d77467734db6f84b3619eeeb6895.tar.xz
qemu-3e8529dd8554d77467734db6f84b3619eeeb6895.zip
meson: fix static flag summary
'static build:' must display value of CONFIG_STATIC rather than value of CONFIG_TOOLS. Signed-off-by: Laurent Vivier <lvivier@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20200917140700.673171-1-lvivier@redhat.com> Signed-off-by: Laurent Vivier <laurent@vivier.eu>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index f4d1ab1096..b26c8bffc6 100644
--- a/meson.build
+++ b/meson.build
@@ -1368,7 +1368,7 @@ summary_info += {'gprof enabled': config_host.has_key('CONFIG_GPROF')}
summary_info += {'sparse enabled': meson.get_compiler('c').cmd_array().contains('cgcc')}
summary_info += {'strip binaries': get_option('strip')}
summary_info += {'profiler': config_host.has_key('CONFIG_PROFILER')}
-summary_info += {'static build': config_host.has_key('CONFIG_TOOLS')}
+summary_info += {'static build': config_host.has_key('CONFIG_STATIC')}
if targetos == 'darwin'
summary_info += {'Cocoa support': config_host.has_key('CONFIG_COCOA')}
endif