summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-04-20 17:33:49 +0200
committerPaolo Bonzini2022-05-07 07:46:58 +0200
commit40c909f534e3f3cd2bcb797b95f96d52e6dd5cdf (patch)
tree3847d413d82d98ad5f813d4cd551bbf77329f56a /meson.build
parentmeson, configure: move Xen detection to meson (diff)
downloadqemu-40c909f534e3f3cd2bcb797b95f96d52e6dd5cdf.tar.gz
qemu-40c909f534e3f3cd2bcb797b95f96d52e6dd5cdf.tar.xz
qemu-40c909f534e3f3cd2bcb797b95f96d52e6dd5cdf.zip
configure, meson: move iasl detection to meson
Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 9 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index 2d54513b9f..448a8dd2a4 100644
--- a/meson.build
+++ b/meson.build
@@ -167,6 +167,12 @@ if 'dtrace' in get_option('trace_backends')
endif
endif
+if get_option('iasl') == ''
+ iasl = find_program('iasl', required: false)
+else
+ iasl = find_program(get_option('iasl'), required: true)
+endif
+
##################
# Compiler flags #
##################
@@ -1584,8 +1590,8 @@ foreach k : get_option('trace_backends')
config_host_data.set('CONFIG_TRACE_' + k.to_upper(), true)
endforeach
config_host_data.set_quoted('CONFIG_TRACE_FILE', get_option('trace_file'))
-if get_option('iasl') != ''
- config_host_data.set_quoted('CONFIG_IASL', get_option('iasl'))
+if iasl.found()
+ config_host_data.set_quoted('CONFIG_IASL', iasl.full_path())
endif
config_host_data.set_quoted('CONFIG_BINDIR', get_option('prefix') / get_option('bindir'))
config_host_data.set_quoted('CONFIG_PREFIX', get_option('prefix'))
@@ -3631,11 +3637,7 @@ summary_info += {'sphinx-build': sphinx_build}
if config_host.has_key('HAVE_GDB_BIN')
summary_info += {'gdb': config_host['HAVE_GDB_BIN']}
endif
-if get_option('iasl') != ''
- summary_info += {'iasl': get_option('iasl')}
-else
- summary_info += {'iasl': false}
-endif
+summary_info += {'iasl': iasl}
summary_info += {'genisoimage': config_host['GENISOIMAGE']}
if targetos == 'windows' and have_ga
summary_info += {'wixl': wixl}