summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2022-04-20 17:33:52 +0200
committerPaolo Bonzini2022-05-07 07:46:58 +0200
commit41f2ae281953c7f7cfc28c5b93f9e0fb65cbd301 (patch)
tree3d9605f0c4a790d24ea257c7735832d480b3a809 /meson.build
parentconfigure: switch string options to automatic parsing (diff)
downloadqemu-41f2ae281953c7f7cfc28c5b93f9e0fb65cbd301.tar.gz
qemu-41f2ae281953c7f7cfc28c5b93f9e0fb65cbd301.tar.xz
qemu-41f2ae281953c7f7cfc28c5b93f9e0fb65cbd301.zip
meson, configure: move --tls-priority to meson
Use the new support for string option parsing. Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6606c9790f..ae3b3a45e7 100644
--- a/meson.build
+++ b/meson.build
@@ -1598,6 +1598,7 @@ foreach k : get_option('trace_backends')
config_host_data.set('CONFIG_TRACE_' + k.to_upper(), true)
endforeach
config_host_data.set_quoted('CONFIG_TRACE_FILE', get_option('trace_file'))
+config_host_data.set_quoted('CONFIG_TLS_PRIORITY', get_option('tls_priority'))
if iasl.found()
config_host_data.set_quoted('CONFIG_IASL', iasl.full_path())
endif
@@ -3820,7 +3821,7 @@ summary(summary_info, bool_yn: true, section: 'Block layer support')
# Crypto
summary_info = {}
-summary_info += {'TLS priority': config_host['CONFIG_TLS_PRIORITY']}
+summary_info += {'TLS priority': get_option('tls_priority')}
summary_info += {'GNUTLS support': gnutls}
if gnutls.found()
summary_info += {' GNUTLS crypto': gnutls_crypto.found()}