summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2022-05-16 16:58:22 +0200
committerThomas Huth2022-05-18 08:54:22 +0200
commit43ecd16678b74b281c3cc7de0dd62a36279b6025 (patch)
tree840fa9624e6d195559508943b708a419f6199349 /meson.build
parenttests/vm: Add capstone to the NetBSD and OpenBSD VMs (diff)
downloadqemu-43ecd16678b74b281c3cc7de0dd62a36279b6025.tar.gz
qemu-43ecd16678b74b281c3cc7de0dd62a36279b6025.tar.xz
qemu-43ecd16678b74b281c3cc7de0dd62a36279b6025.zip
capstone: Allow version 3.0.5 again
According to https://lore.kernel.org/qemu-devel/20200921174118.39352-1-richard.henderson@linaro.org/ there was an issue with Capstone 3.0.4 from Ubuntu 18, which was the reason for bumping our minimum Capstone requirement to version 4.0. And indeed, compiling with that version 3.0.4 from Ubuntu 18.04 still fails (after allowing it with a hack in meson.build). But now that we've dropped support for Ubuntu 18.04, that issue is not relevant anymore. Compiling with Capstone version 3.0.5 (e.g. used in Ubuntu 20.04) seems to work fine, so let's allow that version again. Message-Id: <20220516145823.148450-3-thuth@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 53a4728250..526ff29a86 100644
--- a/meson.build
+++ b/meson.build
@@ -2525,7 +2525,7 @@ capstone = not_found
capstone_opt = get_option('capstone')
if capstone_opt in ['enabled', 'auto', 'system']
have_internal = fs.exists(meson.current_source_dir() / 'capstone/Makefile')
- capstone = dependency('capstone', version: '>=4.0',
+ capstone = dependency('capstone', version: '>=3.0.5',
kwargs: static_kwargs, method: 'pkg-config',
required: capstone_opt == 'system' or
capstone_opt == 'enabled' and not have_internal)