summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2021-04-13 11:27:09 +0200
committerPhilippe Mathieu-Daudé2021-05-02 16:49:34 +0200
commit46369b50ee3f72782507a7f88158fa62753be469 (patch)
treeabe40c7a7b71eab97f51bcc60a9901fe610a0685 /meson.build
parenttarget/mips: Extract load/store helpers to ldst_helper.c (diff)
downloadqemu-46369b50ee3f72782507a7f88158fa62753be469.tar.gz
qemu-46369b50ee3f72782507a7f88158fa62753be469.tar.xz
qemu-46369b50ee3f72782507a7f88158fa62753be469.zip
meson: Introduce meson_user_arch source set for arch-specific user-mode
Similarly to the 'target_softmmu_arch' source set which allows to restrict target-specific sources to system emulation, add the equivalent 'target_user_arch' set for user emulation. Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Message-Id: <20210428170410.479308-12-f4bug@amsat.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d8bb1ec5aa..1ffdc9e6c4 100644
--- a/meson.build
+++ b/meson.build
@@ -1751,6 +1751,7 @@ modules = {}
hw_arch = {}
target_arch = {}
target_softmmu_arch = {}
+target_user_arch = {}
###############
# Trace files #
@@ -2168,6 +2169,11 @@ foreach target : target_dirs
abi = config_target['TARGET_ABI_DIR']
target_type='user'
qemu_target_name = 'qemu-' + target_name
+ if arch in target_user_arch
+ t = target_user_arch[arch].apply(config_target, strict: false)
+ arch_srcs += t.sources()
+ arch_deps += t.dependencies()
+ endif
if 'CONFIG_LINUX_USER' in config_target
base_dir = 'linux-user'
target_inc += include_directories('linux-user/host/' / config_host['ARCH'])