summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2020-08-17 12:47:55 +0200
committerPaolo Bonzini2020-08-21 12:30:21 +0200
commit478e943f515bffb712ff65a85b5db36c90a2f5e7 (patch)
tree500e8167a2136e49e7a17ef19f5ab518d8cdbeb8 /meson.build
parentmeson: convert tests/qtest to meson (diff)
downloadqemu-478e943f515bffb712ff65a85b5db36c90a2f5e7.tar.gz
qemu-478e943f515bffb712ff65a85b5db36c90a2f5e7.tar.xz
qemu-478e943f515bffb712ff65a85b5db36c90a2f5e7.zip
meson: convert audio directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build27
1 files changed, 27 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 99daa91666..e1e70d4b48 100644
--- a/meson.build
+++ b/meson.build
@@ -147,6 +147,20 @@ if 'CONFIG_XKBCOMMON' in config_host
xkbcommon = declare_dependency(compile_args: config_host['XKBCOMMON_CFLAGS'].split(),
link_args: config_host['XKBCOMMON_LIBS'].split())
endif
+pulse = not_found
+if 'CONFIG_LIBPULSE' in config_host
+ pulse = declare_dependency(compile_args: config_host['PULSE_CFLAGS'].split(),
+ link_args: config_host['PULSE_LIBS'].split())
+endif
+alsa = not_found
+if 'CONFIG_ALSA' in config_host
+ alsa = declare_dependency(compile_args: config_host['ALSA_CFLAGS'].split(),
+ link_args: config_host['ALSA_LIBS'].split())
+endif
+jack = not_found
+if 'CONFIG_LIBJACK' in config_host
+ jack = declare_dependency(link_args: config_host['JACK_LIBS'].split())
+endif
spice = not_found
if 'CONFIG_SPICE' in config_host
spice = declare_dependency(compile_args: config_host['SPICE_CFLAGS'].split(),
@@ -217,6 +231,18 @@ liblzfse = not_found
if 'CONFIG_LZFSE' in config_host
liblzfse = declare_dependency(link_args: config_host['LZFSE_LIBS'].split())
endif
+oss = not_found
+if 'CONFIG_AUDIO_OSS' in config_host
+ oss = declare_dependency(link_args: config_host['OSS_LIBS'].split())
+endif
+dsound = not_found
+if 'CONFIG_AUDIO_DSOUND' in config_host
+ dsound = declare_dependency(link_args: config_host['DSOUND_LIBS'].split())
+endif
+coreaudio = not_found
+if 'CONFIG_AUDIO_COREAUDIO' in config_host
+ coreaudio = declare_dependency(link_args: config_host['COREAUDIO_LIBS'].split())
+endif
create_config = find_program('scripts/create_config')
minikconf = find_program('scripts/minikconf.py')
@@ -518,6 +544,7 @@ libqemuutil = static_library('qemuutil',
qemuutil = declare_dependency(link_with: libqemuutil,
sources: genh + version_res)
+subdir('audio')
subdir('io')
subdir('chardev')
subdir('fsdev')