summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorHelge Deller2022-07-19 18:20:42 +0200
committerLaurent Vivier2022-07-25 10:42:11 +0200
commit499d8055379f5beb2ca155c668eca52b8a24321a (patch)
tree24bffb2800645af01ecfb0b80ed6922fb55accd4 /meson.build
parentlinux-user/hppa: Fix segfaults on page zero (diff)
downloadqemu-499d8055379f5beb2ca155c668eca52b8a24321a.tar.gz
qemu-499d8055379f5beb2ca155c668eca52b8a24321a.tar.xz
qemu-499d8055379f5beb2ca155c668eca52b8a24321a.zip
linux-user: Unconditionally use pipe2() syscall
The pipe2() syscall is available on all Linux platforms since kernel 2.6.27, so use it unconditionally to emulate pipe() and pipe2(). Signed-off-by: Helge Deller <deller@gmx.de> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Message-Id: <YtbZ2ojisTnzxN9Y@p100> Signed-off-by: Laurent Vivier <laurent@vivier.eu>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 0 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 8a8c415fc1..75aaca8462 100644
--- a/meson.build
+++ b/meson.build
@@ -2026,15 +2026,6 @@ config_host_data.set('CONFIG_OPEN_BY_HANDLE', cc.links(gnu_source_prefix + '''
#else
int main(void) { struct file_handle fh; return open_by_handle_at(0, &fh, 0); }
#endif'''))
-config_host_data.set('CONFIG_PIPE2', cc.links(gnu_source_prefix + '''
- #include <unistd.h>
- #include <fcntl.h>
-
- int main(void)
- {
- int pipefd[2];
- return pipe2(pipefd, O_CLOEXEC);
- }'''))
config_host_data.set('CONFIG_POSIX_MADVISE', cc.links(gnu_source_prefix + '''
#include <sys/mman.h>
#include <stddef.h>