summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2020-11-18 18:10:51 +0100
committerLaurent Vivier2020-12-13 23:56:16 +0100
commit4a9d5f895adc25f043a382a3d5bf7237905d8991 (patch)
treed785c07d45fbbcc48d1fc532a88f0a2140e3d678 /meson.build
parentconfigure / meson: Move check for sys/signal.h to meson.build (diff)
downloadqemu-4a9d5f895adc25f043a382a3d5bf7237905d8991.tar.gz
qemu-4a9d5f895adc25f043a382a3d5bf7237905d8991.tar.xz
qemu-4a9d5f895adc25f043a382a3d5bf7237905d8991.zip
configure / meson: Move check for sys/kcov.h to meson.build
This check can be done in a much shorter way in meson.build. And while we're at it, rename the #define to HAVE_SYS_KCOV_H to match the other HAVE_someheader_H symbols that we already have. Signed-off-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Message-Id: <20201118171052.308191-6-thuth@redhat.com> [lv: s/signal/kcov/] Signed-off-by: Laurent Vivier <laurent@vivier.eu>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a790cc527c..04cdea75dd 100644
--- a/meson.build
+++ b/meson.build
@@ -839,6 +839,7 @@ config_host_data.set('QEMU_VERSION_MICRO', meson.project_version().split('.')[2]
config_host_data.set('HAVE_DRM_H', cc.has_header('libdrm/drm.h'))
config_host_data.set('HAVE_PTY_H', cc.has_header('pty.h'))
config_host_data.set('HAVE_SYS_IOCCOM_H', cc.has_header('sys/ioccom.h'))
+config_host_data.set('HAVE_SYS_KCOV_H', cc.has_header('sys/kcov.h'))
config_host_data.set('HAVE_SYS_SIGNAL_H', cc.has_header('sys/signal.h'))
ignored = ['CONFIG_QEMU_INTERP_PREFIX'] # actually per-target