summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorAkihiko Odaki2022-07-02 16:25:19 +0200
committerPhilippe Mathieu-Daudé2022-07-13 00:06:02 +0200
commit52eaefd36c33d17c5c52de0d02f1edf7400c0abb (patch)
treeba6e52b6b87e8fa55231cd840ae9cb8967a472ba /meson.build
parentui/cocoa: Fix switched_to_fullscreen warning (diff)
downloadqemu-52eaefd36c33d17c5c52de0d02f1edf7400c0abb.tar.gz
qemu-52eaefd36c33d17c5c52de0d02f1edf7400c0abb.tar.xz
qemu-52eaefd36c33d17c5c52de0d02f1edf7400c0abb.zip
ui/cocoa: Take refresh rate into account
Retrieve the refresh rate of the display and reflect it with dpy_set_ui_info() and update_displaychangelistener(), allowing the guest and DisplayChangeListener to consume the information. The information will be used as a hint how often the display should be updated. For example, when we run 30 Hz physical display updates it is pointless for the guest to update the screen at 60Hz frequency, the guest can spare some work instead. Signed-off-by: Akihiko Odaki <akihiko.odaki@gmail.com> Reviewed-by: Peter Maydell <peter.maydell@linaro.org> Message-Id: <20220702142519.12188-1-akihiko.odaki@gmail.com> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index ad92d288a6..fea3566ea8 100644
--- a/meson.build
+++ b/meson.build
@@ -583,7 +583,8 @@ if get_option('attr').allowed()
endif
endif
-cocoa = dependency('appleframeworks', modules: 'Cocoa', required: get_option('cocoa'))
+cocoa = dependency('appleframeworks', modules: ['Cocoa', 'CoreVideo'],
+ required: get_option('cocoa'))
if cocoa.found() and get_option('sdl').enabled()
error('Cocoa and SDL cannot be enabled at the same time')
endif