summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Huth2022-03-30 13:48:08 +0200
committerThomas Huth2022-04-01 13:06:07 +0200
commit54c9b19421895eddac19444c1de705ef0ddbfe95 (patch)
treede57d17e060dda672e66f1a18c7cccee2dcda58e /meson.build
parenttarget/s390x: Fix determination of overflow condition code after subtraction (diff)
downloadqemu-54c9b19421895eddac19444c1de705ef0ddbfe95.tar.gz
qemu-54c9b19421895eddac19444c1de705ef0ddbfe95.tar.xz
qemu-54c9b19421895eddac19444c1de705ef0ddbfe95.zip
meson.build: Fix dependency of page-vary-common.c to config-poison.h
Before compiling page-vary-common.c, we have to make sure that config-poison.h has been generated (which is in the "genh" list). Signed-off-by: Thomas Huth <thuth@redhat.com> Reviewed-by: Richard Henderson <richard.henderson@linaro.org> Resolves: https://gitlab.com/qemu-project/qemu/-/issues/948 Message-Id: <20220330114808.942933-1-thuth@redhat.com> Signed-off-by: Thomas Huth <thuth@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index aef724ad3c..04ce33fef1 100644
--- a/meson.build
+++ b/meson.build
@@ -2881,7 +2881,7 @@ if get_option('b_lto')
if get_option('cfi')
pagevary_flags += '-fno-sanitize=cfi-icall'
endif
- pagevary = static_library('page-vary-common', sources: pagevary,
+ pagevary = static_library('page-vary-common', sources: pagevary + genh,
c_args: pagevary_flags)
pagevary = declare_dependency(link_with: pagevary)
endif