summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2019-07-24 17:16:22 +0200
committerPaolo Bonzini2020-08-21 12:30:23 +0200
commit5516623020db6a4f3ebee42b2fd6a5c517f939a9 (patch)
treed2862773050115121dc998d484707a1bbd66234b /meson.build
parentmeson: convert replay directory to Meson (diff)
downloadqemu-5516623020db6a4f3ebee42b2fd6a5c517f939a9.tar.gz
qemu-5516623020db6a4f3ebee42b2fd6a5c517f939a9.tar.xz
qemu-5516623020db6a4f3ebee42b2fd6a5c517f939a9.zip
meson: convert migration directory to Meson
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 60313b2eae..9bc1a2ac0d 100644
--- a/meson.build
+++ b/meson.build
@@ -308,6 +308,10 @@ lzo = not_found
if 'CONFIG_LZO' in config_host
lzo = declare_dependency(link_args: config_host['LZO_LIBS'].split())
endif
+rdma = not_found
+if 'CONFIG_RDMA' in config_host
+ rdma = declare_dependency(link_args: config_host['RDMA_LIBS'].split())
+endif
create_config = find_program('scripts/create_config')
minikconf = find_program('scripts/minikconf.py')
@@ -655,6 +659,7 @@ softmmu_ss.add(when: ['CONFIG_FDT', fdt], if_true: [files('device_tree.c')])
common_ss.add(files('cpus-common.c'))
subdir('softmmu')
+subdir('migration')
subdir('monitor')
subdir('replay')