summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé2020-10-06 14:56:01 +0200
committerPaolo Bonzini2020-10-12 17:50:20 +0200
commit555678917697b6bef70e2d07c8a19d199a53b592 (patch)
tree91e53ec62566ae46de4736fcf3d4384780f61f93 /meson.build
parentcrypto: Move the creation of the library to the main meson.build (diff)
downloadqemu-555678917697b6bef70e2d07c8a19d199a53b592.tar.gz
qemu-555678917697b6bef70e2d07c8a19d199a53b592.tar.xz
qemu-555678917697b6bef70e2d07c8a19d199a53b592.zip
authz: Move the creation of the library to the main meson.build
Be consistent creating all the libraries in the main meson.build file. Suggested-by: Paolo Bonzini <pbonzini@redhat.com> Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Message-Id: <20201006125602.2311423-9-philmd@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9c199195bf..2736f74b8f 100644
--- a/meson.build
+++ b/meson.build
@@ -1182,6 +1182,7 @@ sphinx_extn_depends = [ meson.source_root() / 'docs/sphinx/depfile.py',
# Collect sourcesets.
+authz_ss = ss.source_set()
blockdev_ss = ss.source_set()
block_ss = ss.source_set()
bsd_user_ss = ss.source_set()
@@ -1453,6 +1454,15 @@ qemu_syms = custom_target('qemu.syms', output: 'qemu.syms',
# Library dependencies #
########################
+authz_ss = authz_ss.apply(config_host, strict: false)
+libauthz = static_library('authz', authz_ss.sources() + genh,
+ dependencies: [authz_ss.dependencies()],
+ name_suffix: 'fa',
+ build_by_default: false)
+
+authz = declare_dependency(link_whole: libauthz,
+ dependencies: qom)
+
crypto_ss = crypto_ss.apply(config_host, strict: false)
libcrypto = static_library('crypto', crypto_ss.sources() + genh,
dependencies: [crypto_ss.dependencies()],