summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorSunil Muthuswamy2020-10-22 02:27:55 +0200
committerPaolo Bonzini2020-10-26 12:08:39 +0100
commit57e2a1f82c6cf37cbf164d0824cca692e0db7133 (patch)
tree647dacb55812d504ab8ba7989ccc7d5c9703bdba /meson.build
parentconfigure: move install_blobs from configure to meson (diff)
downloadqemu-57e2a1f82c6cf37cbf164d0824cca692e0db7133.tar.gz
qemu-57e2a1f82c6cf37cbf164d0824cca692e0db7133.tar.xz
qemu-57e2a1f82c6cf37cbf164d0824cca692e0db7133.zip
WHPX: Fix WHPX build break
With upstream commit#8a19980e3fc4, logic was introduced to only allow WHPX build on x64. But, the logic checks for the cpu family and not the cpu. On my fedora container build, the cpu family is x86 and the cpu is x86_64. Fixing the build break by checking for the cpu, instead of the cpu family. Signed-off-by: Sunil Muthuswamy <sunilmut@microsoft.com> Message-Id: <SN4PR2101MB0880D706A85793DDFC411304C01D0@SN4PR2101MB0880.namprd21.prod.outlook.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 342b8bcab5..61919c024a 100644
--- a/meson.build
+++ b/meson.build
@@ -204,7 +204,7 @@ else
have_xen_pci_passthrough = false
endif
if not get_option('whpx').disabled() and targetos == 'windows'
- if get_option('whpx').enabled() and cpu != 'x86_64'
+ if get_option('whpx').enabled() and host_machine.cpu() != 'x86_64'
error('WHPX requires 64-bit host')
elif cc.has_header('WinHvPlatform.h', required: get_option('whpx')) and \
cc.has_header('WinHvEmulation.h', required: get_option('whpx'))