summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann2021-05-19 07:39:32 +0200
committerGerd Hoffmann2021-05-21 09:42:44 +0200
commit58d3f3ff8da8d1f0ea917c661f306c42d0a69e7b (patch)
treee742fcf9418329d95a6da830883371383d25824e /meson.build
parentui/spice-display: check NULL pointer in interface_release_resource() (diff)
downloadqemu-58d3f3ff8da8d1f0ea917c661f306c42d0a69e7b.tar.gz
qemu-58d3f3ff8da8d1f0ea917c661f306c42d0a69e7b.tar.xz
qemu-58d3f3ff8da8d1f0ea917c661f306c42d0a69e7b.zip
build: add separate spice-protocol config option
When implementing spice vdagent protocol in qemu we only need the spice-protocol package for that, spice-server is not needed. So go split those two build dependencies. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-id: 20210519053940.1888907-1-kraxel@redhat.com Message-Id: <20210519053940.1888907-2-kraxel@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1559e8d873..632b380738 100644
--- a/meson.build
+++ b/meson.build
@@ -458,11 +458,15 @@ if 'CONFIG_LIBJACK' in config_host
endif
spice = not_found
spice_headers = not_found
+spice_protocol = not_found
if 'CONFIG_SPICE' in config_host
spice = declare_dependency(compile_args: config_host['SPICE_CFLAGS'].split(),
link_args: config_host['SPICE_LIBS'].split())
spice_headers = declare_dependency(compile_args: config_host['SPICE_CFLAGS'].split())
endif
+if 'CONFIG_SPICE_PROTOCOL' in config_host
+ spice_protocol = declare_dependency(compile_args: config_host['SPICE_PROTOCOL_CFLAGS'].split())
+endif
rt = cc.find_library('rt', required: false)
libdl = not_found
if 'CONFIG_PLUGIN' in config_host