summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau2022-05-25 16:41:39 +0200
committerMarc-André Lureau2022-05-28 11:42:56 +0200
commit5b9e7d05d63372540139ba70a8f7c3699d7751b6 (patch)
tree9d34796965a3f21e94b4c9c394ffc2ccdeebe0e0 /meson.build
parentqga/wixl: simplify some pre-processing (diff)
downloadqemu-5b9e7d05d63372540139ba70a8f7c3699d7751b6.tar.gz
qemu-5b9e7d05d63372540139ba70a8f7c3699d7751b6.tar.xz
qemu-5b9e7d05d63372540139ba70a8f7c3699d7751b6.zip
qga/wixl: replace QEMU_GA_MSI_MINGW_BIN_PATH with glib bindir
Use more conventional variables to set the location of pre-built DLL/bin. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Konstantin Kostiuk <kkostiuk@redhat.com> Message-Id: <20220525144140.591926-15-marcandre.lureau@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index df7c34b076..bf318d9cbb 100644
--- a/meson.build
+++ b/meson.build
@@ -466,7 +466,10 @@ add_project_arguments(config_host['GLIB_CFLAGS'].split(),
native: false, language: ['c', 'cpp', 'objc'])
glib = declare_dependency(compile_args: config_host['GLIB_CFLAGS'].split(),
link_args: config_host['GLIB_LIBS'].split(),
- version: config_host['GLIB_VERSION'])
+ version: config_host['GLIB_VERSION'],
+ variables: {
+ 'bindir': config_host['GLIB_BINDIR'],
+ })
# override glib dep with the configure results (for subprojects)
meson.override_dependency('glib-2.0', glib)