summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini2021-10-13 13:19:00 +0200
committerPaolo Bonzini2022-02-21 10:35:54 +0100
commit5dc4618e781f36c4bea1b0cdd1bea75b48640c5a (patch)
tree27456281d3deb8947606d02f7023c6ac7be4f880 /meson.build
parentmeson, configure: move ntddscsi API check to meson (diff)
downloadqemu-5dc4618e781f36c4bea1b0cdd1bea75b48640c5a.tar.gz
qemu-5dc4618e781f36c4bea1b0cdd1bea75b48640c5a.tar.xz
qemu-5dc4618e781f36c4bea1b0cdd1bea75b48640c5a.zip
configure, meson: move CONFIG_IASL to a Meson option
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 8 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index aefe8681b9..8df40bfac4 100644
--- a/meson.build
+++ b/meson.build
@@ -1463,7 +1463,9 @@ foreach k : get_option('trace_backends')
config_host_data.set('CONFIG_TRACE_' + k.to_upper(), true)
endforeach
config_host_data.set_quoted('CONFIG_TRACE_FILE', get_option('trace_file'))
-
+if get_option('iasl') != ''
+ config_host_data.set_quoted('CONFIG_IASL', get_option('iasl'))
+endif
config_host_data.set_quoted('CONFIG_BINDIR', get_option('prefix') / get_option('bindir'))
config_host_data.set_quoted('CONFIG_PREFIX', get_option('prefix'))
config_host_data.set_quoted('CONFIG_QEMU_CONFDIR', get_option('prefix') / qemu_confdir)
@@ -1957,7 +1959,6 @@ config_host_data.set('HAVE_NTDDSCSI', have_ntddscsi)
ignored = ['CONFIG_QEMU_INTERP_PREFIX', # actually per-target
'HAVE_GDB_BIN']
arrays = ['CONFIG_BDRV_RW_WHITELIST', 'CONFIG_BDRV_RO_WHITELIST']
-strings = ['CONFIG_IASL']
foreach k, v: config_host
if ignored.contains(k)
# do nothing
@@ -1966,8 +1967,6 @@ foreach k, v: config_host
v = '"' + '", "'.join(v.split()) + '", '
endif
config_host_data.set(k, v)
- elif strings.contains(k)
- config_host_data.set_quoted(k, v)
elif k.startswith('CONFIG_')
config_host_data.set(k, v == 'y' ? 1 : v)
endif
@@ -3375,6 +3374,11 @@ summary_info += {'sphinx-build': sphinx_build}
if config_host.has_key('HAVE_GDB_BIN')
summary_info += {'gdb': config_host['HAVE_GDB_BIN']}
endif
+if get_option('iasl') != ''
+ summary_info += {'iasl': get_option('iasl')}
+else
+ summary_info += {'iasl': false}
+endif
summary_info += {'genisoimage': config_host['GENISOIMAGE']}
if targetos == 'windows' and have_ga
summary_info += {'wixl': wixl}